Commit 0580c360 authored by Ruslan Zakirov's avatar Ruslan Zakirov
Browse files

update M::I

parent bff7ec3c
......@@ -4,7 +4,7 @@ build_requires:
IPC::Open2: 0
Test::More: 0
distribution_type: module
generated_by: Module::Install version 0.62
generated_by: Module::Install version 0.63
license: perl
name: RT-Extension-CommandByMail
no_index:
......
......@@ -639,7 +639,9 @@ sub _version_check {
# check for version numbers that are not in decimal format
if ( ref($cur) or ref($min) or $cur =~ /v|\..*\./ or $min =~ /v|\..*\./ ) {
if ( $version::VERSION or defined( _load('version') ) ) {
if ( ( $version::VERSION or defined( _load('version') )) and
version->can('new')
) {
# use version.pm if it is installed.
return (
......@@ -750,4 +752,4 @@ installdeps ::
__END__
#line 988
#line 990
......@@ -28,7 +28,7 @@ BEGIN {
# This is not enforced yet, but will be some time in the next few
# releases once we can make sure it won't clash with custom
# Module::Install extensions.
$VERSION = '0.62';
$VERSION = '0.63';
}
# Whether or not inc::Module::Install is actually loaded, the
......@@ -51,6 +51,22 @@ not:
END_DIE
}
# If the script that is loading Module::Install is from the future,
# then make will detect this and cause it to re-run over and over
# again. This is bad. Rather than taking action to touch it (which
# is unreliable on some platforms and requires write permissions)
# for now we should catch this and refuse to run.
if ( -f $0 and (stat($0))[9] > time ) {
die << "END_DIE";
Your installer $0 has a modification time in the future.
This is known to create infinite loops in make.
Please correct this, then run $0 again.
END_DIE
}
use Cwd ();
use File::Find ();
use File::Path ();
......
......@@ -6,7 +6,7 @@ use Module::Install::Base;
use vars qw{$VERSION $ISCORE @ISA};
BEGIN {
$VERSION = '0.62';
$VERSION = '0.63';
$ISCORE = 1;
@ISA = qw{Module::Install::Base};
}
......
#line 1
package Module::Install::Base;
$VERSION = '0.62';
$VERSION = '0.63';
# Suspend handler for "redefined" warnings
BEGIN {
......
......@@ -11,7 +11,7 @@ use ExtUtils::MakeMaker ();
use vars qw{$VERSION $ISCORE @ISA};
BEGIN {
$VERSION = '0.62';
$VERSION = '0.63';
$ISCORE = 1;
@ISA = qw{Module::Install::Base};
}
......
......@@ -6,7 +6,7 @@ use Module::Install::Base;
use vars qw{$VERSION $ISCORE @ISA};
BEGIN {
$VERSION = '0.62';
$VERSION = '0.63';
$ISCORE = 1;
@ISA = qw{Module::Install::Base};
}
......
......@@ -6,7 +6,7 @@ use Module::Install::Base;
use vars qw{$VERSION $ISCORE @ISA};
BEGIN {
$VERSION = '0.62';
$VERSION = '0.63';
$ISCORE = 1;
@ISA = qw{Module::Install::Base};
}
......
......@@ -7,7 +7,7 @@ use ExtUtils::MakeMaker ();
use vars qw{$VERSION $ISCORE @ISA};
BEGIN {
$VERSION = '0.62';
$VERSION = '0.63';
$ISCORE = 1;
@ISA = qw{Module::Install::Base};
}
......
......@@ -6,7 +6,7 @@ use Module::Install::Base;
use vars qw{$VERSION $ISCORE @ISA};
BEGIN {
$VERSION = '0.62';
$VERSION = '0.63';
$ISCORE = 1;
@ISA = qw{Module::Install::Base};
}
......@@ -123,9 +123,9 @@ sub auto_provides {
require Module::Build;
my $build = Module::Build->new(
dist_name => $self->{name},
dist_version => $self->{version},
license => $self->{license},
dist_name => $self->name,
dist_version => $self->version,
license => $self->license,
);
$self->provides(%{ $build->find_dist_packages || {} });
}
......
......@@ -6,7 +6,7 @@ use Module::Install::Base;
use vars qw{$VERSION $ISCORE @ISA};
BEGIN {
$VERSION = '0.62';
$VERSION = '0.63';
$ISCORE = 1;
@ISA = qw{Module::Install::Base};
}
......
......@@ -6,7 +6,7 @@ use Module::Install::Base;
use vars qw{$VERSION $ISCORE @ISA};
BEGIN {
$VERSION = '0.62';
$VERSION = '0.63';
$ISCORE = 1;
@ISA = qw{Module::Install::Base};
}
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment