Commit 18ef9b24 authored by Alex Vandiver's avatar Alex Vandiver
Browse files

The alluded-to deficiency is not a concern in perl ≥ 5.8.3

The comment and code were added in RT 2.1.38, which only required perl
5.6.1; the perl version was increased to 5.8.3 to cover a large number
of encoding bugs, such as the one this comment was likely alluding to.
parent a275a7fa
......@@ -254,9 +254,6 @@ sub loc_fuzzy {
my $self = shift;
return '' if !defined $_[0] || $_[0] eq '';
# XXX: work around perl's deficiency when matching utf8 data
return $_[0] if Encode::is_utf8($_[0]);
return $self->LanguageHandle->maketext_fuzzy( @_ );
}
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment