jekyll-scholar-extras.gemspec 1.14 KB
Newer Older
1
2
3
4
5
6
7
8
9
10
# -*- encoding: utf-8 -*-
lib = File.expand_path('../lib/', __FILE__)
$:.unshift lib unless $:.include?(lib)

require 'jekyll/scholar/version'

Gem::Specification.new do |s|
  s.name        = 'jekyll-scholar-extras'
  s.version     = Jekyll::ScholarExtras::VERSION.dup
  s.platform    = Gem::Platform::RUBY
root's avatar
root committed
11
12
13
14
  s.authors     = ['Hiren Patel']
  s.email       = 'hiren.patel at uwaterloo dot ca'
  s.homepage    = ''
  s.licenses    = ['MIT']
15
16
17
18
19
20
21
22
23
24
  s.summary     = 'Extras for Jekyll extensions for the academic blogger jekyll-scholar.'
  s.description = %q{
    Extras for jekyll-scholar.  Customized bibliography and details generators.
  }.gsub(/\s+/, ' ')
  
  s.date        = Time.now

  s.required_rubygems_version = '>= 1.3.6'
  s.rubyforge_project = s.name

root's avatar
root committed
25
26
27
28
  s.add_runtime_dependency('jekyll', '~> 3.0')
  s.add_runtime_dependency('jekyll-scholar', '~> 5.7')
  s.add_runtime_dependency('citeproc-ruby', '~> 1.0')
  s.add_runtime_dependency('bibtex-ruby', '~> 4.0')
29
30

  s.files        = `git ls-files`.split("\n")
31
  s.test_files   = `git ls-files -- {samples,test,spec,features}/*`.split("\n")
32
33
34
35
36
37
  s.executables  = []
  s.require_path = 'lib'
  
end

# vim: syntax=ruby