Commit 33bacc74 authored by rmrf's avatar rmrf Committed by Hiren

TODO: cucumber is broken

parent bcb16c39
source :rubygems
source 'https://rubygems.org'
gemspec
gem 'unicode_utils'
group :development do
group 'development' do
gem 'debugger'
if RUBY_VERSION >= '2.2'
gem 'test-unit'
else
gem 'minitest', '< 5.0'
end
gem 'rake'
gem 'redgreen', '~> 1.2'
gem 'shoulda', '~> 3.5'
gem 'cucumber', '1.3.11'
gem 'redcarpet'
gem 'launchy', '~> 2.3'
gem 'unicode_utils'
gem 'simplecov', '~>0.9', :require => false
gem 'rubinius-coverage', :platform => :rbx
gem 'coveralls', :require => false
end
group :debug do
if RUBY_VERSION > '2.0'
gem 'byebug', '~>3.5', :require => false, :platform => :mri
else
gem 'debugger', '~>1.6', :require => false, :platform => [:mri_19, :mri_20]
end
gem 'rubinius-compiler', '~>2.0', :require => false, :platform => :rbx
gem 'rubinius-debugger', '~>2.0', :require => false, :platform => :rbx
end
require 'bundler'
begin
Bundler.setup(:default, :development)
rescue Bundler::BundlerError => e
$stderr.puts e.message
$stderr.puts "Run `bundle install` to install missing gems"
exit e.status_code
end
require 'rake'
require 'jekyll/scholar/version'
require 'cucumber/rake/task'
Cucumber::Rake::Task.new(:features)
task :default => [:features]
require 'coveralls/rake/task'
Coveralls::RakeTask.new
task :test_with_coveralls => [:features, 'coveralls:push']
......@@ -23,7 +23,7 @@ Gem::Specification.new do |s|
s.rubyforge_project = s.name
s.add_runtime_dependency('jekyll', '~> 3.0')
s.add_runtime_dependency('jekyll-scholar', '~> 5.7')
# s.add_runtime_dependency('jekyll-scholar', '~> 5.7')
s.add_runtime_dependency('citeproc-ruby', '~> 1.0')
s.add_runtime_dependency('bibtex-ruby', '~> 4.0')
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment