Commit 947e7439 authored by Sylvester Keil's avatar Sylvester Keil

support ruby 2.2

parent cc7296ba
......@@ -2,24 +2,24 @@ source 'https://rubygems.org'
gemspec
group :development do
gem 'minitest', '< 5.0'
gem 'test-unit' if RUBY_VERSION.start_with?('2.2')
gem 'rake'
gem 'redgreen', '~> 1.2'
gem 'shoulda', '~> 3.5'
gem 'rr', '~> 1.1'
gem 'cucumber', '1.3.11'
gem 'redcarpet', '~> 3.1'
gem 'launchy', '~> 2.1.2'
gem 'redcarpet'
gem 'launchy', '~> 2.3'
gem 'unicode_utils'
gem 'simplecov', '~>0.8', :require => false
gem 'simplecov', '~>0.9', :require => false
gem 'rubinius-coverage', :platform => :rbx
gem 'coveralls', :require => false
end
group :debug do
gem 'debugger', '~>1.6', :require => false, :platform => :mri
gem 'debugger', '~>1.6', :require => false, :platform => [:mri_19, :mri_20]
gem 'rubinius-compiler', '~>2.0', :require => false, :platform => :rbx
gem 'rubinius-debugger', '~>2.0', :require => false, :platform => :rbx
end
......@@ -16,10 +16,6 @@ require 'test/unit'
require 'jekyll/scholar'
World do
include Test::Unit::Assertions
end
TEST_DIR = File.join('/', 'tmp', 'jekyll')
def run_jekyll(options = {})
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment