Commit aa8f24e8 authored by Sylvester Keil's avatar Sylvester Keil

use byebug to debug ruby 2.2

parent 3d484160
......@@ -25,7 +25,12 @@ group :development do
end
group :debug do
gem 'debugger', '~>1.6', :require => false, :platform => [:mri_19, :mri_20]
if RUBY_VERSION > '2.0'
gem 'byebug', '~>3.5', :require => false, :platform => :mri
else
gem 'debugger', '~>1.6', :require => false, :platform => [:mri_19, :mri_20]
end
gem 'rubinius-compiler', '~>2.0', :require => false, :platform => :rbx
gem 'rubinius-debugger', '~>2.0', :require => false, :platform => :rbx
end
......@@ -6,7 +6,11 @@ rescue LoadError
end
begin
require 'debugger'
if RUBY_VERSION > '2.0'
require 'byebug'
else
require 'debugger'
end
rescue LoadError
# ignore
end
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment