Commit 58b80089 authored by rmrf's avatar rmrf

Start using c++14. Why not?

parent 279077f9
cmake_minimum_required(VERSION 2.6)
project(systemc-clang)
# Use C++ standard version to c++14
set(CMAKE_CXX_STANDARD 14)
# Always keep it on
set(CMAKE_CXX_STANDARD_REQUIRED ON)
option (USE_SAUTO
"Use suspension-automata library." OFF
......
......@@ -28,7 +28,7 @@ set -x CXX clang++
set -x LLVM_CXX_FLAGS (eval $LLVMCONFIG --cxxflags)
# Generate all the flags.
set -x LLVM_CXX_FLAGS "$LLVM_CXX_FLAGS -fvisibility-inlines-hidden"
set -x LLVM_CXX_FLAGS "$LLVM_CXX_FLAGS -fvisibility-inlines-hidden -faligned-allocation"
set -x LLVM_LIBS (eval $LLVMCONFIG --libs)
set -x LLVM_LD_FLAGS (eval $LLVMCONFIG --ldflags)
set -x LLVM_LD_FLAGS (echo $LLVM_LD_FLAGS | sed 's/ *$//g')
......@@ -112,8 +112,8 @@ namespace scpar {
}
}
vector < string > getTemplateArguments() {
vector < string > template_arguments;
vector<string> getTemplateArguments() {
vector<string> template_arguments;
// type_vector_t::iterator
// for ( auto mit = template_types_.begin(); mit != template_types_.end(); ++mit ) {
for ( auto const &mit: template_types_ ) {
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment