Commit 5ff92b4d authored by Steve Weber's avatar Steve Weber
Browse files

rt1188031

parent 4f279f84
......@@ -20,28 +20,6 @@
include:
- {{_systemd.sls}}
{# OLD
{{sls}}:
pkg.installed:
- pkgs:
- git
file.directory:
- name: {{vars.dir_src}}
- user: {{vars.user}}
- group: {{vars.group}}
- mode: '0775'
- makedirs: True
git.latest:
- name: {{vars.repo}}
- target: {{vars.dir_src}}
- user: {{vars.user}}
- rev: {{vars.repo_branch}}
- branch: {{vars.repo_branch}}
- watch_in:
- service: {{sls}} service
#}
{{sls}}:
pkg.installed:
......@@ -133,18 +111,18 @@ include:
{{sls}} post_update:
pkg.installed:
- pkgs:
#- python3-venv
- python3.7-venv
- python-virtualenv
- python3-venv
###- python3.7-venv
#- python-virtualenv
- gcc
- clang
- python-dev
#- python-dev
- python3-dev
- libpq-dev
- libssl-dev
#- python-psycopg2
## libssl-dev is needed for building psycopg2 with ssl support.
#- python3-wheel
- python3-wheel
# GRR: does not work - python3-psycopg2
#- python3-dev
#- libpq-dev
......@@ -167,30 +145,30 @@ include:
{#
{{sls}} uwsgi pkg:
pkg.installed:
- pkgs:
- uwsgi-plugin-python3
- uwsgi-plugin-python
- require_in:
- service: {{sls}} service
{{sls}} uwsgi pkg:
pkg.installed:
- pkgs:
- uwsgi-plugin-python3
- uwsgi-plugin-python
- require_in:
- service: {{sls}} service
{{sls}} uwsgi config:
file.managed:
- name: {{vars.dir_uwsgi}}/wsgi.ini
- source: salt://{{tpldir}}/_data/wsgi.ini
- template: jinja
- context:
vars: {{vars|json}}
- mode: '0640'
- user: {{vars.user}}
- group: {{vars.group}}
- makedirs: True
- require_in:
- service: {{sls}} service
- watch_in:
- service: {{sls}} service
{{sls}} uwsgi config:
file.managed:
- name: {{vars.dir_uwsgi}}/wsgi.ini
- source: salt://{{tpldir}}/_data/wsgi.ini
- template: jinja
- context:
vars: {{vars|json}}
- mode: '0640'
- user: {{vars.user}}
- group: {{vars.group}}
- makedirs: True
- require_in:
- service: {{sls}} service
- watch_in:
- service: {{sls}} service
#}
......@@ -212,7 +190,7 @@ include:
- require:
- file: {{sls}} service
{#
{{sls}} check for security issues in packages:
cmd.run:
- name: bash -c "source '{{vars.dir_venv}}/bin/activate' && ( python -m pip install --upgrade safety ; safety check -r ./requirements.txt ; )"
......@@ -221,4 +199,3 @@ include:
- env:
- LC_ALL: C.UTF-8
- LANG: C.UTF-8
#}
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment